Search found 5 matches

by blady
Mon Oct 02, 2017 9:30 pm
Forum: Editor
Topic: Sprite Swap Tips/Suggestions
Replies: 37
Views: 1249

Re: Sprite Swap Tips/Suggestions

Alright, first of all, that works! There is something weird though (don't worry, everything is fixed for me now ;) ) This line at the start of the OnStateEnter function worked for me: pack_renderer = animator.GetComponent<CreaturePackRenderer>(); The odd thing is that pack_renderer is not null at th...
by blady
Mon Oct 02, 2017 8:08 pm
Forum: Editor
Topic: Sprite Swap Tips/Suggestions
Replies: 37
Views: 1249

Re: Sprite Swap Tips/Suggestions

Welp... I seems like it still doesn't work.. I remains null, even after this fix. I thought it worked, but that was still within the "bad" framework of instantiating them when needed. Any other suggestions? EDIT: To clarify, I don't disable them anymore. This is what I do and what happens: 1. I crea...
by blady
Sat Sep 30, 2017 5:22 pm
Forum: Editor
Topic: Sprite Swap Tips/Suggestions
Replies: 37
Views: 1249

Re: Sprite Swap Tips/Suggestions

You are a life saver man! I tried so many things, but this one seemed to solve it! Couple of things though: 1. I added a debug.log to the start of the Innit and it seems to run quite a lot (every frame). This might just be my code though. 2. The line you gave me is faulty. I chanegd it to: if(pack_a...
by blady
Sat Sep 30, 2017 2:01 pm
Forum: Editor
Topic: Sprite Swap Tips/Suggestions
Replies: 37
Views: 1249

Re: Sprite Swap Tips/Suggestions

Hey Chong, I got an issue with using the creature pack with object pooling. Everyone works for the first time when I spawn an enemy, but whenever I disable the gameobject/renderer/meshrenderer for a sec it looses a conenction in CreaturePackStateMachineBehavior: creature_renderer.pack_player = null....
by blady
Wed Sep 13, 2017 11:17 am
Forum: Editor
Topic: Sprite Swap Tips/Suggestions
Replies: 37
Views: 1249

Re: Sprite Swap Tips/Suggestions

Heey Chong, the programmer here. Took a while to get the verification email, so that's why i'm posting a bit late. First of all, thank you for your ongoing support and the amazing software! Something definitely went wrong while exporting the files, cause none of the giving files where accepted into ...