Godot export res:// and user:// fix?

Discuss issues pertaining to the various game/web runtimes of Creature here.
User avatar
Melimeli
Posts: 21
Joined: Thu Apr 30, 2020 6:22 am

Re: Godot export res:// and user:// fix?

Post by Melimeli » Sat Jun 06, 2020 12:44 am

I keep getting errors when I try to recompiled the godot binary, what version of godot did you use?

I'm using the latest 3.2.2-beta4 from here: https://github.com/godotengine/godot/tree/3.2

Unfortunately it's necessary to use 3.2.2-beta4 because 3.2.1-stable web export audio stutter a lot on mobile +_+

From what I heard the master branch is from godot 4.0 but that one seems far away from being stable so I'm not sure if that should be used?

Code: Select all

modules\creaturegodot\CreatureMetaData.cpp:102:34: warning: lambda capture 'this' is not used [-Wunused-lambda-capture]
    auto getJsonNodeFromArray = [this](JsonNode& json_obj, int idx)
                                 ^~~~
modules\creaturegodot\CreatureMetaData.cpp:518:31: warning: lambda capture 'this' is not used [-Wunused-lambda-capture]
                                                                auto getColorFloat = [this](uint8_t val_in)
                                                                                      ^~~~
modules\creaturegodot\CreatureMetaData.cpp:579:8: warning: unused variable 'radius' [-Wunused-variable]
                auto radius = (float)morph_data.morph_res * 0.5f;
                     ^
3 warnings generated.
[Initial build] Compiling ==> modules\creaturegodot\CreatureModule.cpp
modules\creaturegodot\CreatureModule.cpp:1566:4: error: cannot use 'throw' with exceptions disabled
                        throw "CreatureManager::PoseCreature() - Invalid animation name!";
                        ^
modules\creaturegodot\CreatureModule.cpp:1614:7: warning: unused variable 'index' [-Wunused-variable]
                int index = 0;
                    ^
1 warning and 1 error generated.
em++: error: 'C:/emsdk/upstream/bin\clang++.exe -target wasm32-unknown-emscripten -D__EMSCRIPTEN_major__=1 -D__EMSCRIPTEN_minor__=39 -D__EMSCRIPTEN_tiny__=15 -D_LIBCPP_ABI_VERSION=2 -Dunix -D__unix -D__unix__ -Werror=implicit-function-declaration -Xclang -nostdsysteminc -Xclang -isystemC:\emsdk\upstream\emscripten\system\include\libcxx -Xclang -isystemC:\emsdk\upstream\emscripten\system\lib\libcxxabi\include -Xclang -isystemC:\emsdk\upstream\emscripten\system\lib\libunwind\include -Xclang -isystemC:\emsdk\upstream\emscripten\system\include\compat -Xclang -isystemC:\emsdk\upstream\emscripten\system\include -Xclang -isystemC:\emsdk\upstream\emscripten\system\include\libc -Xclang -isystemC:\emsdk\upstream\emscripten\system\lib\libc\musl\arch\emscripten -Xclang -isystemC:\emsdk\upstream\emscripten\system\local\include -Xclang -isystemC:\Users\Helaine\.emscripten_cache\wasm\include -DEMSCRIPTEN -fignore-exceptions -fno-inline-functions -c -std=gnu++14 -Os -fno-exceptions -fno-rtti -Wall -Werror=return-type -DJAVASCRIPT_ENABLED -DUNIX_ENABLED -DNO_THREADS -DNO_SAFE_CAST -DJAVASCRIPT_EVAL_ENABLED -DNDEBUG -DPTRCALL_ENABLED -DGDSCRIPT_ENABLED -DMINIZIP_ENABLED -DZSTD_STATIC_LINKING_ONLY -D_USE_MATH_DEFINES -DGLM_FORCE_RADIANS -Ithirdparty\libpng -Ithirdparty\zstd -Ithirdparty\zlib -Iplatform\javascript -I. -Imodules\creaturegodot -Imodules\creaturegodot\glm -Imodules\creaturegodot\gason modules\creaturegodot\CreatureModule.cpp -Xclang -isystemC:\emsdk\upstream\emscripten\system\include\SDL -c -o modules\creaturegodot\CreatureModule.javascript.opt.bc -mllvm -combiner-global-alias-analysis=false -mllvm -enable-emscripten-sjlj -mllvm -disable-lsr' failed (1)
scons: *** [modules\creaturegodot\CreatureModule.javascript.opt.bc] Error 1
scons: building terminated because of errors.

chong
Posts: 1082
Joined: Thu Feb 19, 2015 2:21 am

Re: Godot export res:// and user:// fix?

Post by chong » Sun Jun 07, 2020 12:17 am

Just checked in a change to remove the exception. You can sync again.

User avatar
Melimeli
Posts: 21
Joined: Thu Apr 30, 2020 6:22 am

Re: Godot export res:// and user:// fix?

Post by Melimeli » Sun Jun 07, 2020 2:55 am

Thank you!!!! It's working without having to copy files now!!

Post Reply