Creature3D often fails to run

A place to discuss Creature3D, the Procedural 3D Animation Tool
Post Reply
masonwheeler
Posts: 3
Joined: Tue Nov 10, 2020 3:58 pm

Creature3D often fails to run

Post by masonwheeler » Tue Nov 10, 2020 4:03 pm

After seeing the GamesFromScratch post, I downloaded and installed Creature3D. When I try to run it, it displays the splash screen over a window for approximately 3 seconds, and then the program shuts down with no explanation or error message provided. This doesn't always happen -- I managed to get the program to launch on the third attempt -- but failing twice before it works is not a good look.

Any idea what's going on and how to fix it? Currently running Windows 10 Home, build 19041, 64-bit, on a gaming system with pretty good hardware.

chong
Posts: 1143
Joined: Thu Feb 19, 2015 2:21 am

Re: Creature3D often fails to run

Post by chong » Tue Nov 10, 2020 11:15 pm

Hello,

I think it's the server which it is contacting having some issues. Will look into making this more stable for the next Alpha release.

Thanks

masonwheeler
Posts: 3
Joined: Tue Nov 10, 2020 3:58 pm

Re: Creature3D often fails to run

Post by masonwheeler » Tue Nov 10, 2020 11:30 pm

Stability is good. Better error reporting is also good.

chong
Posts: 1143
Joined: Thu Feb 19, 2015 2:21 am

Re: Creature3D often fails to run

Post by chong » Tue Nov 10, 2020 11:47 pm

Just pushed out a minor update for server ping, not sure if it completely addresses your issue but you can try it:
https://www.kestrelmoon.com/creature3D/ ... _setup.exe

Next upcoming update will look into fixing these bugs and have a primary focus on improving the rigging workflow, starting with a GPU accelerated weight painting process.

Cheers

masonwheeler
Posts: 3
Joined: Tue Nov 10, 2020 3:58 pm

Re: Creature3D often fails to run

Post by masonwheeler » Tue Nov 10, 2020 11:49 pm

I just realized something. Why is a program that is free, with no registration required, pinging a server on startup and then crashing if this doesn't go through?

That kinda sounds like a privacy concern...

chong
Posts: 1143
Joined: Thu Feb 19, 2015 2:21 am

Re: Creature3D often fails to run

Post by chong » Tue Nov 10, 2020 11:55 pm

There is no personal data that is sent at all for the server part. This is to retrieve any update information for the App ( if the modules need any updates ).

Cheers

Post Reply